Wie die meisten Webseiten nutzen wir Cookies. Nähere Informationen dazu, wie wir mit diesen Cookies umgehen, können Sie in unseren Datenschutzbestimmungen lesen.   Einverstanden
 
 

3D Forum > Array + Curve mod --> eine verwirrende Angelegenheit

Array + Curve mod --> eine verwirrende Angelegenheit

31.08.2019 18:27
 
ForrestSa. 31 Aug. 2019, 18:27 Uhr
Hey BlenderChecker,

Bin auf ein Problem gestoßen wobei ich euren Rat benötige. Ich versuche die Ketten eines Panzers, oder einer Pistenraupe nachzubauen. Das funktioniert soweit schon super, bis zu dem punkt an dem ich versuche zu animieren.
Solange ich mein Object welches der parent für meine Ketten ist auf der Y Achse bewege, läuft alles wie am schnürchen und die einzelnen kettenglieder flutschen entlang der Curve die ich eingerichtet habe.
Auf den Anderen achsen funktioniert das aber weniger gut.
Wenn ich mein object auf der Z achse bewege, entfernt sich die Curve auf der x Achse. Auf der x Achse sieht das ganze nichtt besser aus, sonder nur verwirrender. Denn eine Bewegung meines Objects auf der x achse beeinflusst aus irgend einem grund die skalierung der Curve.

Kann mir jemand sagen was hier passiert bitte?

Die blender Dat ist im Anhang

PS: vllt kann mir auch noch jemand sagen warum das ganze mit einem Cicle nciht funktioniert sondern nur mit einer curve ??

MfG und Danke schon im vorraus.

Forrest
 
TilesSa. 31 Aug. 2019, 18:53 Uhr
Hi Forrest,

Ich werde leider aus dem File nicht schlau. Das ist wirklich was für die Cracks ^^

Baust du das nach einem Tutorial nach?
 
ForrestSa. 31 Aug. 2019, 23:11 Uhr
@Tiles:
Haha, dann hab ich die frage vllt nicht richtig gestellt Du hast mir schon bei komplizierteren Sachen geholfen

Es sind mehrere Tutorials. Einzeln haben alle nicht funktioniert weil sie über blender 2.6 bis alpha 2.8 verteilt waren -.-.
Aber alle zusammen haben mich zu meinem bisherigen Ergebnis gebracht.
Darf ich hier Externe Links posten?
Ich hoffe ja, sonst bitte bescheid sagen:







 
TilesSo. 01 Sep. 2019, 08:09 Uhr
Natürlich darfst du verlinken. Ich habe die Tutorials mal eingebunden smile

Und ich bin immer noch aufgeschmissen. Manchmal komme ich eben an meine Grenzen ^^
 
KastomiumMo. 02 Sep. 2019, 07:44 Uhr
O.K., ich geb`s auf.
So wie`s im ersten Video gezeigt wird funktionierts. Zumindest solange die Richtung ( Drehung um die Z-Achse ) nicht geändert wird.

Hatte damals dieses Video benutzt:



und längst nicht alles verstanden was ich da nachgebastelt habe.
Nach etwas Nacharbeit hinsichtlich der korrekten Funktionen läuft alles wie es soll ( nur nicht zuviel Gas geben, sonst erkundet jedes Kettenglied seine Umgebung selbstständig ).

Empfehlung:
Peinlich genau auf die Achsen der einzelnen Objekte achten, deren Ausrichtung und Position.
Hatte ich nicht gemacht. Deswegen zweimal.
 
TilesMo. 02 Sep. 2019, 08:18 Uhr
Hmmm. Sprich dir funken die Weltachsen dazwischen, richtig? Hast du es schon mit Parenting und lokalen Achsen probiert? Also das ganze Ding an ein Empty parenten zum Beispiel.
 
KastomiumMo. 02 Sep. 2019, 10:07 Uhr
@Tiles:
Falls Deine Frage an mich gerichtet ist:
Hatte versucht mit dem Parenting, Set Origin und CTRL+A in Forrest´s Datei was zu bewirken, mit wenig Erfolg. Auch mit Emptys und/oder Constraints kam ich nicht weiter.

Hab dann das 5 Min.-Tut nachgebastelt. Funktioniert auch, solange man geradeaus Fährt.
Ist wohl so, daß das Curve Child vom Panda ist, damit sich beides zusammen bewegt. Problem:
Kettenglied scheint am Ursprungsort verbleiben zu müssen, damit die Kette funktioniert ( in Y-Richtung ). Verändert man die Position des Curve in X-Richtung oder dreht diese um die Z-Achse, so arbeitet das Ganze nicht mehr zusammen. Wenigstens nicht so wie es sollte.
Hoffe jemand hat `ne einfache Lösung.

Hab z.Zt. keinen Plan wie ich`s bei meinem T-70 zusammengefummelt habe. Ehrlich gesagt auch wenig Neigung mich da nochmal reinzufinden. Bin froh daß es läuft.

Wie gesagt, mit dem 30 Min-Tut hab ich´s damals hingekriegt. Hab aber ein paar Tage gebraucht.
 
TilesMo. 02 Sep. 2019, 10:55 Uhr
Deswegen ja das ganze Paket an ein Empty parenten. Das sollte eigentlich funktionieren. Aber ja, bei bestimmten Sachen ist Blender eben komisch -.-
 
ForrestMi. 04 Sep. 2019, 16:13 Uhr
Hallo freunde,

Viel zu oft bleiben meine merkwürdigen Anfragen meist ohne Lösung, deshalb freue ich mich umso mehr mal selber eine gefunden zu haben.



Der beste weg war es, das ganze über Driver zu managen, was in diesem video sehr schön illustriert wird.

Trotzdem danke für die Tipps und sicherlich bis bald

MfG Forrest
 
TilesMi. 04 Sep. 2019, 17:51 Uhr
Gut dass du da noch eine Lösung gefunden hast smile
 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006