Wie die meisten Webseiten nutzen wir Cookies. Nähere Informationen dazu, wie wir mit diesen Cookies umgehen, können Sie in unseren Datenschutzbestimmungen lesen.   Einverstanden
 
 

3D Forum > UV-Editor Relax-Tool erzeugt rotierende Cluster

UV-Editor Relax-Tool erzeugt rotierende Cluster

11.12.2018 17:14
 
McFlyDi. 11 Dez. 2018, 17:14 Uhr
Mal wieder ich - sorry. Aber ich bin auf ein Problem gestoßen, wo ich einfach nicht dahinter komme, was der Fehler ist.
Ich habe mal vor längerer Zeit eine Hand modelliert (ist auch in meiner Galerie) und diese jetzt zu Übungszwecken hervor gekramt um mit dem UV-Editor herum experimentiert. Die Hand habe ich mit dem Seam-Tool in verschiedene Bereiche geschnitten und diese dann mit dem Relax-Tool bearbeitet. Das hat auch soweit geklappt bis auf den oberen Bereich am Daumen. Hier fangen die Cluster an zu rotieren, sobald ich das Relax-Tool anwende. Ich habe die Hand in diesem Bereich schon auf verschiedene Art und Weise gecuttet und mit verschiedenen Einstellungen im Relax-Tool experimentiert aber es ist immer das selbe an dieser Stelle.Ich habe leider keine Ahnung, wo das Problem liegt. Das Objekt habe ich untersucht, ob es an dieser Stelle irgend welche Netzfehler gibt kann aber überhaupt nichts finden. Alles sind saubere Quads.
Ehrlich gesagt stehe ich ziemlich auf dem Schlauch und weiß gar nicht, was ich hier falsch mache.

Wenn jemand einen Tipp hätte, wäre ich echt Dankbar.
 
 
SleepyDi. 11 Dez. 2018, 17:40 Uhr
Als Tipp wie ich solche Probleme löse:

Schneide das Cluster in kleinere Teile und relaxe die separat. Die Cluster wo sich sauber relaxen lassen, schiebst du zur Seite und machst solange weiter bis du den Übeltäter gefunden hast.

Meisten liegen solche Probleme daran weil der Algorithmus zu keinem Ergebnis kommt. Er will beispielsweise Relaxen kann aber nicht weil zwei Teile noch direkt oder indirekt zusammenhängen. Er relaxt, dreht das Objekt und läuft gegen ne Mauer. Es kommt kein Ergebnis dabei raus.

Wenn du die Teile kleiner machst, findest du das Cluster das mit mit einem anderen zusammenhängt.
 
McFlyDi. 11 Dez. 2018, 17:55 Uhr
Danke Sleepy.
Das Problem liegt irgendwie am Daumenansatz. Genauer gesagt am Poly oben rechts. Soweit hatte ich das Problem schon eingegrenzt. Ich hatte hier mal den Bereich gecuttet und separat relaxed sowie du es mir gerade rätst. Es hat auch rotiert und ich war echt erstaunt, weil das Model meiner Meinung nach hier sauber aufgebaut ist. Wie du sagst, scheint der Algorithmus hier Probleme zu machen obwohl ich mich frage warum. An der Stelle ist das Netz nicht wirklich komplex aufgebaut.

Bleibt mir an dieser Stelle dann keine andere Möglichkeit die Cluster von Hand zu entzerren? Oder wie machst du das dann?
 
SleepyDi. 11 Dez. 2018, 19:55 Uhr
Das hatte ich mir schon gedacht das Problem ist, ich muss das Mesh nach dem Screenshot bewerten aber ich rate einfach mal ins blaue:

1.Du hast den Daumen der im Prinzip wie ein Zylinder aufgebaut
2.Du hast vorne Fingerkuppel die solltest du einmal vertical cuten also von Nagelbett zum Fingerabdruck (keine Ahnung wie der Bereich heißt smile ) Da würde sich dann auch anbieten den Cut dort weiterzuziehen in Richtung Mittelbereich Daumen/Zeigefinger. Da würde es sich wiederum anbieten dort einen Cut zu setzen wo du den Daumen normalerweise abschneiden würdest. (Sorry für die Blutige Ausdruckweise)

3.So das Hauptproblem dürfte aber das Nagelbett sein Das würde ich erstmal komplett vom restlichen Daumen lösen.

4.Dann solltest du noch einen Cut oberhalt des daumens ziehen. Somit besteht dein Daumen aus 3 Teile.
Daumen Linke + Rechteseite + Nagelbett.

Sollte das auch nicht klappen lad mir mal bitte das Mesh als FBX hoch.


 
McFlyMi. 12 Dez. 2018, 04:24 Uhr
Danke Sleepy.

Ja - Hand und cutten hört ich immer blutig an
Wie gesagt hatte ich es schon auf verschiedene Arten mit Nähten versehen (weniger blutig ?) Auch so wie du es beschreibst.
Ich suche mir immer mal wieder ältere Sachen raus, die ich gemacht habe, wenn mich was bestimmtes Interessiert. Eigentlich wollte ich nur was mit dem UV-Editor probieren und bin dann zufällig auf das Problem gestoßen und dann irgendwie daran hängen geblieben.

Hier mal die Datei als fbx.
 
SleepyMi. 12 Dez. 2018, 12:06 Uhr
Ich arbeite mit Maya aber das UV-Mapping ist immer das selbe.

Wie oben bereits erwähnt steckt da immer ein algorithmus dahinter diese unterscheiden sich von Programm zu Programm.

Dein Problem ist folgendes als Beispiel:

Du hast einen Hund der Fiffi heißt und der an einer Latterne festgebunden ist. Du rufst fiffi und er kommt einfach nicht! (Weil er ja festgebunden ist)

Bei deiner Hand ist das genau so:
Der algorithmus versucht die UVs auszubreiten und wie Kaugumie nach außen zu ziehen, nur geht das nicht weil deine Finger an verschiedenen Stellen miteinander verbunden ist.

Hier ein Beispiel:http://prntscr.com/lty59y

Auf den ersten Blick sieht das Okay aus. Aber ich schneide die UV mal weiter auseinander relaxe einmal und verbinde nur eine Edge wieder. (Roter Stich)

http://prntscr.com/lty6h5

Du siehst sofort das diese Teile so nicht zusammenpassen KÖNNEN. Wenn du das doch tust, erzwingst du quasi distortions an diesen Stellen.
Willst du an diesen Stellen also keine Distoritions haben, musst du deine UV weiter zercutten und dann kommt auch der Algorithmus besser damit klar.
Sind die teile miteinander verbunden, versucht der Algorithmus die UVs einige mal auseinander zu bekommen und zieht einmal an der einen UV und einmal an der anderen, Dadurch dreht sich die UV immer ein bisschen.

Vergleichbar mit einem Puzellteil das an einer bestimmten Stelle nicht passt das du aber mit gewalt reinhämmerst. Wenn das Automatisch geschehen würde und du die passende Stelle finden willst, dann würdest du das Puzzelteil auch mehrmals drehen um auf ein Ergebnis zu kommen.

Für dieses Problem gibt es einen Namen: Das nennt sich Non-Manifold geometry ich denke in verbindung mit Max wirst du hierzu einiges im Netz finden.

Kurz: Manifold Geometry ist ein Mesh das sich aufgrund seiner Beschaffenheit nicht relaxen lässt.

Stell dir einen Cube vor bei dem du die obere Flläche und eine Fläche an der Seite löschen tust. Nun verbindest du die Edges an den Ecken miteinander und willst diese Releaxen. Das geht so nur wenn die Edges an den richtigen Stellen zercuttet sind.

Hier mal das beispiel:http://prntscr.com/ltybmf

Die schwarzen Flächen sind Rückseiten und die Frauen Flächen sind die Vorderseiten.
Hier hab ich vorderseite mit der Rückseite des Faces Links geweldet.

Klar das der Algorithmus hiermit nicht klarkommt. Da er nicht weiß wo vorne, hinten oben und unten ist.
Bei deiner Hand ist das nun nicht so krass wie bei dem Würfel aber das Basis Problem ist das selbe.

Wie gesagt such einfach mal nach Manifold Geometry und überleg dir wo du die Cuts am besten setzen kannst, damit das nicht passiert.

 
McFlyMi. 12 Dez. 2018, 17:15 Uhr
Hallo Sleepy,
erst mal Danke für deine Mühe.
Jetzt muss ich aber gestehen, dass ich es immer noch nicht ganz checke. Wahrscheinlich bin ich zu doof - das wird´s wohl sein
Ich habe mir dein Beispiel mit dem Finger angeschaut. Er sieht doch korrekt aus. Bei dem Beispiel, wo du zeigst, das die Cluster mit einer Ecke verbunden sind, verstehe ich nicht, was da falsch dran sein soll.
Ich hab auch mal nach "Non-Manifold geometry" gegoogelt. Da geht´s meiner Meinung nach eher um unsaubere Geometrie statt ums unwarpen oder verstehe ich das jetzt auch nicht Richtig. Meine Hand ist aber sauber modelliert.
Aber ich habe folgendes gemacht. Die Hand habe ich am Daumenansatz gecuttet (da ist es wieder das böse Blut) und zwar so, dass man es als Steifen aufklappen kann. Dann den Streifen Relaxed - Ergebnis der Cluster rotiert.
Jetzt habe ich den Cluster immer kleiner gemacht und die Stücke dann immer wieder relaxed und wieder vernäht, bis ich auf genau das Polygon gestoßen bin, was das Problem verursacht (siehe Bild). Das Polygon sieht ganz normal aus. Es leuchtet mir echt nicht ein, warum der Algorithmus genau hier ein Problem hat. Das Mesh ist hier sauber modelliert.
Es wird wohl so sein, dass man in solchen Fällen damit leben muss.

 
 
SleepyMi. 12 Dez. 2018, 18:27 Uhr
An der Stelle das kann ich dir sagen: Weil du ne Spirale hast.

Dein Edgeflow läuft oben oben sprialförmig nach unten.

Räum dein Mesh mal so auf, dass die Edges gerade verlaufen.

 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006