Wie die meisten Webseiten nutzen wir Cookies. Nähere Informationen dazu, wie wir mit diesen Cookies umgehen, können Sie in unseren Datenschutzbestimmungen lesen.   Einverstanden
 
 

3D Forum > Probleme mit dem Texture Atlas in Blender

Probleme mit dem Texture Atlas in Blender

07.05.2018 19:33
 
mc477Mo. 07 Mai. 2018, 19:33 Uhr
Hallo leute, folgende problem habe ich mit dem Texture atlas addon.
wenn ich eine uv map erstellen wiill verhaut es mir immer wieder die uv wie ich sie gelegt hatte

in atlas:
so habe ich die UV gelegt

nach schließen:
hier sieht man das es bereits einige UV verhaut

erneutes öffnen:
die hälfte der gelegten UV map ist zerschossen

an was kann das liegen?
anbei noch die bilder und die blend datei
danke für die hilfe
 
TilationMo. 07 Mai. 2018, 21:12 Uhr
Mal ohne mir die Daten angesehen zu haben:

In Blender muss jeder Datensatz einen Besitzer haben.
Die 2 Im Screenshot sagt, dass es 2 Besitzer gibt. Ein mal ist der der Cube, dem die Textur zugewiesen ist und einmal ist da der Virtuelle besitzer, den man erstellt, wenn man auf die 2 Klickt. Ein Virtueller Besitzer kann durch Klick auf das F erstellt werden.
Bei UV-Maps wird es sich ähnlich verhalten.

Beim Speichern der Datei werden nur Datenblöcke gesichert, die MIN einen Besitzer haben.

Tino
 
 
TilesDi. 08 Mai. 2018, 08:09 Uhr
Hm, hier zerhauts gar nichts. Aber du zeigst im ersten Shot auch gar nicht alle Geometrie an. Ist das vielleicht dein Problem?

Man kann ja zwischen zwei Anzeigemodi wechseln. Mit und ohne Sync. Mit Sync an wird nur die Geometrie im UV Image Editor angezeigt den du auch im 3D View ausgewählt hast.
 
 
mc477Mi. 09 Mai. 2018, 18:02 Uhr
hi leute, ich habs nochmal gecheckt, in sync is es.. ich werde das jetzt so machen das ich das UV layout exportiere und dann nochmals lege da es mir dennoch immer wieder das vorhin gelegte layout verstellt....

oder da ich ja das objekt von texture atlas habe, kann ich die UV map zu den anderen objekten kopieren?
 
TilesDo. 10 Mai. 2018, 08:40 Uhr
Wie gesagt, hier verschwindet gar nichts. Und das meinte ich ja mit dem Sync: Sync ausmachen, dann ist alle Geometrie sichtbar. Mit Sync an ist immer nur der Meshteil sichtbar den du auch ausgewählt hast.

 
mc477Do. 10 Mai. 2018, 10:56 Uhr
Ich glaube ich habe mich nicht richtig ausgedrückt.. Ich meinte nicht das die Geometrie bzw UV verschwindet mit dem Texture Atlas, es verschiebt mir nach drücken auf finish manual unwrap die halbe von mir gelegte UV map. Wie soll ich ohne sync sehen ob ich UV überlagere?
 
TilesDo. 10 Mai. 2018, 12:37 Uhr
Ah, wait. du hast da mehrere Meshes oder wie? Tatsächlich. Hm, du könntest sie fürs UV Mappen joinen, und danach wieder separate by loose Parts machen smile

Für ein Objekt, du kannst doch im UV Editor ohne Sycn nach Patches auswählen. Und wenn du das dann verschiebst siehst du ja was drunter ist.

Du könntest auch Pack Islands machen. Dann überlagert da nichts mehr, und alle Teile sind im 0/1 UV Space. Sofern das UV Mapping korrekt ist, und da nicht UV Teile gefaltet wurden. Aber das sieht man in der Regel.

Wieso es dir allerdings Teile verschiebt, keine Ahnung. Hast du da vielleicht noch das Transformtool aktiv?
 
mc477Do. 10 Mai. 2018, 14:25 Uhr
oke jetzt haben wir uns verstanden . Der Texture Atlas ist ja dazu da das er das joinen automatisch macht und nach getaner arbeit wieder separiert aber die UV so belässt wie man sie gelegt hat.
Das mit den Pack Island ist keine option da ich ja gewisse UV größer bzw kleiner skalieren muss damit mehr bzw weniger details in der normal map sichtbar ist.
Alle Modifier wurden vorher bereits angewandt.
Deswegen ärgert mich dieses Addon zurzeit ein wenig.
Mein workflow:
-ich kliche auf start manual unwrap--> es generiert eine kopie des meshes mit allen objekten gejoint.
-ich bearbeite die UV map so wie ich sie brauche
-Anschließend klicke ich auf finish manual unwrap--> das vorhin erzeugte objeket mit gejointen objekten verschwindet aber die UV map wurde auf die original Objekte angewand.
NUR, sobald ich das mache verschiebt es mir die hälfte der UV´s und ich weiß nicht warum bzw finde den fehler
 
TilesDo. 10 Mai. 2018, 15:03 Uhr
Ja. Das mit dem Addon ging unter

Ich vermute mal dass das eben dein Problem ist. Dass das Addon da einen Bug hat.

Das mit den Pack Island ist keine option da ich ja gewisse UV größer bzw kleiner skalieren muss damit mehr bzw weniger details in der normal map sichtbar ist.


Das macht Pack Island nicht. Wenn du einen UV Patch skalierst, dann bleibt der auch nach dem Pack Islands so gross wie du ihn skaliert hast. Pack Island packt die Dinger nur nebeneinander.

Du kannst sogar das automatische drehen abschalten, im Last Operator. Und da auch einen Abstand zwischen den UV Patches einstellen.
 
animelixDo. 10 Mai. 2018, 15:21 Uhr
Evtl: haben deine Originalobjekte alle transformationen angewendet? (StrgA: aplly rotation scale transformation)
 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006