3D Forum > Kontur-Shader in mental ray

Kontur-Shader in mental ray

21.03.2016 17:10
 
McFlyMo. 21 Mär. 2016, 17:10 Uhr
Sorry Leute für die Frage aber ich krieg´s nicht hin.

Zum Problem. Ich wollte bei einem Objekt nur die Kontur rendern lassen in mental ray. Da gibt es ja diverse Kontur Shader aber ich bekomme die nicht zum laufen. Gemäß Autodesk Knowledge muss man, bevor man die Shader überhaupt benutzen kann erst die erweiterten mental ray Funktionen freischalten. Dazu gibt es von Autodesk folgende Anleitung, nach der ich vorgegangen bin:

Verwenden Sie einen Texteditor und öffnen Sie die Datei CurrentDefaults.ini .
Diese Datei befindet sich im Ordner C:Benutzer AppDataLocalAutodesk3ds Max2016 - 64bitENUen-USdefaultsMAX .

Suchen Sie den Abschnitt mit dem Titel "Einstellung mental ray-Erweiterungen".
;mental ray extensions preference
; kDefault_CustomAttribsActive=1 == mental ray extensions at on
; kDefault_CustomAttribsActive=1 == mental ray extensions at off
[F00 58F67D6C 4FCF3BC3]
;mental ray extensions = off
kDefault_CustomAttribsActive=1
Löschen Sie das Semikolon am Anfang der Zeile, ; mental ray-Erweiterungen = Aus.
Dadurch wird die Linie von einem Kommentar in den aktiven Code verändert, wobei die Einstellung aus aktiviert ist.

So aktivieren Sie die Anzeige für mental ray-Erweiterungen:

Verwenden Sie einen Texteditor und öffnen Sie die Datei CurrentDefaults.ini .
Diese Datei befindet sich im Ordner C:Benutzer AppDataLocalAutodesk3ds Max2016 - 64bitENUen-USdefaultsMAX .

Suchen Sie den Abschnitt mit dem Titel "Einstellung mental ray-Erweiterungen".
Platzieren Sie das Semikolon an den Anfang der Linie ; mental ray-Erweiterungen = aus (oder ändern Sie die Einstellung von aus zu ein).


Das habe ich gemacht aber der Reiter unter "Einstellungen" um die erwiterten Einstellungen vorzunehmen erscheint nicht und somit kann ich auch die Kontur-Shader nicht nützen. Aktuell nehme ich halt das Ink and Paint-Mat was auch geht aber mich würde ja schon interessieren, wie ich die Shader zum laufen kriege.

 
GuyGoodMo. 21 Mär. 2016, 20:02 Uhr
Ich habe das mal kurz probiert und bei mir funktioniert es wie folgt:

in der ini datei habe ich bei
kDefault_CustomAttribsActive=1 -> mental ray extensions are enabled
nur das semikolon gelöscht. Damit werden die Shader freigeschalten.

Dann habe ich einfach nur im Material bei den "Mental Ray connections" in den Slot "contour" den Contour Simple shader eingefügt.

Im Renderer-Dialog musste ich noch bei der Sampling Methode auf "Classic Raytraced" stellen und eben nur bei "enable contours" ein Häkchen setzen. Das wars und es ging.

Ich weiß gar nicht so richtig, welchen Reiter du freischalten möchtest, mit den Einstellungen in der Ini-Datei schaltest du nur die erweiterten Shader quasi frei, so habe ich das jetzt jedenfalls verstanden, denn ohne diese zu aktivieren, fehlten mir nur die "Contour Simple" und andere Shader.

Wenn das hier jetzt nicht hilft, beschreibe eventuell nochmal genau, was nicht geht.
 
McFlyDi. 22 Mär. 2016, 05:00 Uhr
Danke GuyGood,

das war die Lösung. Ja jetzt geht es. Entweder habe ich das mit dem Reiter falsch interpretiert oder wie auch immer.
Jedenfalls habe ich nicht die "Classic Raytrayced"-Methode gewählt gehabt. Das habe ich aber nirgendwo gelesen das man das so machen soll - hmm...

Fazit - Problem gelöst und vielen Dank an dich! smile
 
GuyGoodDi. 22 Mär. 2016, 10:32 Uhr
Kein Problem, bei mir ging es auch erst nicht beim kurzen Testen und dann habe ich zufällig so einen Beitrag diesbezüglich aber für Maya gefunden und habe dann nat. das gleiche in Max probiert und dann ging es auch bei mir smile Freut mich, dass es geklappt hat.
 
McFlyDi. 22 Mär. 2016, 15:45 Uhr
GuyGood, jetzt habe ich nochmals in der Hilfe nachgeschaut. Wenn man als Suchbegriff "mental ray kontur" eingibt bekommt man in der Hilfe zu diesem Thema folgendes unter Punkt eins zu lesen:

So fügen Sie einer mental ray-Renderausgabe Konturen hinzu:
Wählen Sie "Anpassen" Einstellungen. Öffnen Sie die Registerkarte "mental ray", und aktivieren Sie die Option "mental ray-Erweiterungen aktivieren".


Hier eben der Hinweis auf eine Registerkarte. Ich dachte ursprünglich nach anpassen der ini-Datei würde ein zusätzlicher Reiter bei Anpassen/Einstellungen entstehen, wo man die mental ray-Erweiterungen aktivieren/deaktivieren kann.
 
GuyGoodDi. 22 Mär. 2016, 15:53 Uhr
Ja, das habe ich auch gelesen, den Tab gab es bei mir nicht. Habe jetzt hier auf Arbeit nochmal geschaut, in 3dsMax 2014 gibt es diesen Tab Die Hilfe ist diesbezüglich also nicht aktuell, aber die Einstellung in dem Tab macht ja im Prinzip das gleiche.
 
McFlyDi. 22 Mär. 2016, 15:58 Uhr
Ich war noch am überlegen, ob ich diesen Tab nicht kenne. Wusste es aber nicht mehr genau. Ach ja, der Hinweis mit der veralteten Hilfe ist gut. Ist mir schon sehr oft aufgefallen, dass da mal manches überarbeitet gehört. Man (ich zumindest) schaut ja öfters mal nach was so Sache ist
 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006