3D Forum > 3D Puppenhaus Animation

3D Puppenhaus Animation

07.08.2015 16:28
 
GeronnymoooFr. 07 Aug. 2015, 16:28 Uhr
Hallo Zusammen,

ich hab eine dringende Frage zu einem Problem das während meines Projektes aufgekommen ist.
Ich möchte eine durchgehende Kamerafahrt durch 6 Puppenhäuser animieren. Das bekomme ich leider nicht so hin. Ich kann nicht alle Häuser in eine Scene "mergen". Sonst wir die Datei zu groß.

Ich musste mir für eine Ausstellung eine Notlösung überlegen. Am 17.08. habe ich meine Bachelorprüfung, bei der die Kamerafahrt richtig funktionieren muss...

Über Tipps und Hinweise wäre ich super dankbar.

Hier die Notlösung:
https://vimeo.com/133647194

Viele Grüße
Ronja
 
jonnydjangoFr. 07 Aug. 2015, 16:44 Uhr
Wieviele Polys hat denn eins der Häuser? Sieht eigentlich recht lowpoly aus.
 
GeronnymoooFr. 07 Aug. 2015, 17:08 Uhr
also eins das ich gerade geöffnet habe hat 519,224 Polys.

Bei den anderen hab ich es noch nicht gecheckt.
 
AndiGFr. 07 Aug. 2015, 17:08 Uhr
Hi,

Du solltest vielleicht bis zu einer bestimmten Einstellung (Kameraentfernung) jeweils mit einer Textur für das nächste Puppenhaus arbeiten und die Einzelbilder der Szenen dann zusammensetzen.
 
GeronnymoooFr. 07 Aug. 2015, 17:17 Uhr
Ich hab die einzelnen Sequenzen (je 500 Frames) je mit 3 Häusern gerendert.
Ich musste die schwarzen Blenden als Unterbrechungen dazwischen schieben, weil ich die Sequenzen sonst nicht hintereinander geschnitten bekommen hätte.

Ich hab gerade noch einmal das Haus von 1970 gecheckt. Da sind es 1,140,228 Polygone.

Die Erkenntnis die ich schon gewonnen habe ist, dass ich die Kamerafahrt verlangsamen muss, je näher sie am nächsten Haus ist - damit die Geschwindigkeit gleich bleibt und es nicht anfängt zu ruckeln. Den Bildausschnitt des Hauses wieder genauso zu treffen ist das größte Problem, bzw muss ich auch irgendwie die Brennweite der Kamera ändern schätze ich...

Ohjee...
 
AndiGFr. 07 Aug. 2015, 17:33 Uhr
Etwas genauer: Du hast jeweils zwei Szenen pro Haus, eine mit dem 'Objekt'-Haus im Haus,
eine Szene mit dem 'Textur'-Haus im Haus. Bis zu einer gewissen Entfernung (Frame 150 z.B)
erkennt der Betrachter den Unterschied nicht. Du renderst also jeweils Frame 1-150 mit
der 'Textur'-Szene und Frame 151-500 mit der 'Objekt'-Szene, wobei jede Objekt-Szene jeweils
die Textur des nächsten Hauses enthält. ;-)
 
GeronnymoooFr. 07 Aug. 2015, 17:49 Uhr
Ja ich verstehe was du meinst aber dennoch ist das Problem mit dem Übergang dadurch noch nicht gelöst. Bislang habe ich sogar 3 Szenen pro Haus.

Beispiel:
1 Haus(1950): leeres Haus in dem nur das Esszimmer eingerichtet ist.
2 Haus(1960): komplettes Haus das auf dem Tisch des Hauses 1 steht.
3 Haus(1970): komplettes Haus das auf dem Tisch des Hauses 2 steht.

in der nächsten Szene rutscht jedes Haus eine Position weiter.
1 Haus(1960): leeres Haus in dem nur das Esszimmer eingerichtet ist.
2 Haus(1970): komplettes Haus das auf dem Tisch des Hauses 1 steht.
3 Haus(1980): komplettes Haus das auf dem Tisch des Hauses 2 steht.

usw.

Das letzte Frame aus der ersten Szenerie muss aber genauso aussehen wie das erste erste der zweiten.

So sieht das ganze aktuell aus:

 
 
AndiGFr. 07 Aug. 2015, 18:02 Uhr
Ich hätte gedacht das der Übergang Textur -> Objekte bis zu einer bestimmten
Kameraentfernung nicht bemerkbar ist. Stell doch mal eine Plane mit der Textur
ins jeweilige Puppen-Zimmer und mach einen AB-Test.
 
GeronnymoooFr. 07 Aug. 2015, 18:17 Uhr
Ach ich hab's dann wohl doch noch nicht gerafft.
Du meinst das ich das Rendering des nächsten Hauses als Textur z.B. auf eine Plane lege, die dann auf dem Tisch "steht"?

Was ist ein AB-Test?
 
AndiGFr. 07 Aug. 2015, 18:22 Uhr
Korrekt. Oder ins Puppen-Zimmer stellen. Dann Kamera-Abstände ausprobieren mit:
A: Objekte; B: Texturen, und sehen ab wann ein Unterschied optisch wahrnehmbar ist.
 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006