3D Forum > Fehler beim Export von Animationen in FBX-Format

Fehler beim Export von Animationen in FBX-Format

27.07.2015 16:54
 
RuhnMo. 27 Jul. 2015, 16:54 Uhr
Hallöchen,

ich bin grade etwas verwirrt und am verzweifeln, weil ich nicht weiss, woran das liegen kann:
Ich habe eine Blender-Datei mit Objekt, Bones und mehreren, einzelnen Animationen dafür.

Diese Datei exportiere ich als FBX.

Öffne ich diese FBX-Datei jetzt in Unity, existieren die Animationen zwar, machen aber alle die gleiche Bewegung wie die Animation, die ich zuletzt bearbeitet habe.

In Blender sieht alles jedoch ganz normal aus und jede Animation macht was sie soll.

Ist das nur nen Fehler in den Export-Einstellungen? Oder hilft es Blender noch einmal herunter zu laden?
Hattet ihr überhaupt schonmal so einen Fehler? Habt ihr irgendwelche Tipps?

Er scheint irgendwie nur eine Animation zu exportieren, wenn mehrere da sind, scheint er die zu überschreiben...


LG

Ruhn

 
TilesMo. 27 Jul. 2015, 17:56 Uhr
Hallo Ruhn,

Bevor wir da weiter dran rumrätseln, wie importierst du denn die Animation? Mit dem alten Legacy System, oder mit dem Mecanim System?

Wenn du mit dem Legacy System importierst wird imho immer nur eine Animation importiert. Die einzelnen Clips kannst du dann aber hinten im Reiter einzeln erstellen.
 
SleepyMo. 27 Jul. 2015, 18:40 Uhr
Ich weiß ja jetzt nicht was du animieren möchtest aber bei einem Chrakter kannst du doch beispeislweise auch alles in eine Animation packen da du eh immer zu idle zukehrst.

zb
1.Idle,
2.idle rennen
3.rennen idle

Und dies in einer Animation! In Unity kannst du dann zb die Idle auf Frame 1 aufrufen oder Idle zu rennen von Frame 2 bis Frame 10 direkt danach direkt die rennen zu Idle Animation von Frame 11 bis Frame 22 usw.

Ich finde das leichter zu handhaben da du alles in einem Film hast.
 
RuhnMo. 27 Jul. 2015, 23:48 Uhr
Danke für eure schnellen Antworten.

@Tiles
Ohje, so genau kann ich dir das garnicht sagen, ich arbeite noch nicht lang mit Unity. Wir nutzen die Version 4.5.0f6, falls die Angabe weiterhilft.

Ich habe die besagte Datei an einem anderen PC in ein anderes Unity importiert, hier wird alles korrekt abgespielt.
Deine Überlegung, dass es am Import liegen könnte und nicht am Export scheint richtig zu sein...
Frage mich nur, was mein Kumpel bei sich verstellt hat, dass es nichtmehr richtig importiert wird



@Sleepy
Jup, das wäre auch unser Notfallplan gewesen, aber es hat vorher ja schon reibungslos funktioniert, erst seit geraumer zeit tritt das Problem auf.

Ich würde jetzt ungern jede Animation jedes Characters in unserem Spiel nochmal überarbeiten müssen, obwohl es vorher ja schon funktioniert hat und der fehler möglicherweise nur irgendeine Einstellungssache ein könnte^^
(Ich mein gut, so viel arbeit ist es nicht, aber wenn es sich durch ne einfache Einstellung vermeiden lässt...)

Ich finde es mit einzelnen Animationen übersichtilicher smile Ansonsten muss man den anderen Team-Mitgliedern immer eine Liste hinterlassen welche Frames zu welcher Animation gehören, dann hat man wieder eine ewige Zettelwirtschaft. ^^
 
TilesDi. 28 Jul. 2015, 08:23 Uhr
Das hat nichts mit der Unity Version zu tun. Ob ihr Mecanim oder Legacy verwendet solltest du eigentlich leicht rausfinden können. Mecanim ist ein eigener Editor mit Nodes. Das Animator Fenster (Nicht zu verwechseln mit dem Animation Fenster, in dem du Keyframes setzen kannst ... ). Und auch der Import läuft ein wenig anders ab. Vor allem musst du im Rig tab den Animationstypen auf Legacy stellen. Sonst geht Unity davon aus dass du Mecanim vewenden willst. Siehe angehängter Shot.

Bezüglich der Clips importieren, ich selber habe das nie gemacht, sondern einfach einen grossen Clip erstellt. Und mir die Nummern notiert welche Animation was ist. Wo genau es jetzt bei dir klemmt kann ich deswegen nicht sagen, sorry. Vielleicht vergisst dein Freund auch schlicht das Ding auf Legacy umzustellen beim Import. Oder er stellt es auf Legacy, und ihr arbeitet mit Mecanim.

Hier mal ein paar weiteführende Links. Vielleicht findest du da ja deine Lösung:

http://answers.unity3d.com/questions/212774/exporting-multiple-animations-from-blender.html

http://zakjr.com/blog/blender-to-unity-workflow-part-7/

http://docs.unity3d.com/Manual/Splittinganimations.html
 
 
vidiDi. 28 Jul. 2015, 14:31 Uhr
Wenn du mit dem Legacy System importierst wird imho immer nur eine Animation importiert.


Also das spielt keine Rolle weilche Option da bei Rig ausgewählt wird, es werden bei Animation immer alle Clips seperat gelistet.

alles in eine Animation packen da du eh immer zu idle zukehrst.

zb
1.Idle,
2.idle rennen
3.rennen idle

Und dies in einer Animation! In Unity kannst du dann zb die Idle auf Frame 1 aufrufen oder Idle zu rennen von Frame 2 bis Frame 10 direkt danach direkt die rennen zu Idle Animation von Frame 11 bis Frame 22 usw.

Ich finde das leichter zu handhaben da du alles in einem Film hast.


Denke nicht das ist einfacher und auch nicht gängige Methode.

http://docs.unity3d.com/Manual/Splittinganimations.html

Wenn schon als ganze Sequence, dann wie Tiles schreib extra noch mal händisch splitten, aber da ja Unity die Animationen auch so schön einzeln aufgelistet importieren kann ist das ja nur doppelt gemacht Arbeit..

Aber an dieser Stelle kann ich auch Akeytsu empfehlen . Mann speichert alle Ani Clips automatisch schön übersichtlich in einer Animationsbank und Unity übernimmt das 1A un mit gün loop match..
 
RuhnDo. 30 Jul. 2015, 08:50 Uhr
Huhu,

so, ich weiss nicht wie, aber es funktioniert wieder... ich habe eine neue FBX Exportiert und die funktioniert bei beiden... Dabei haben wir eigentlich nichts geändert...

Scheint als wäre es letztendlich doch nen Exportierungsfehler von Blender gewesen? Unity hat bei ihm auch manchmal die Angewohnheit sich aufzuhängen oder etwas herum zu zicken und Dinge nicht richtig wiederzugeben, vielleicht war einfach nen Neustart des Programmes vor dem Import notwendig...

War nur nicht das erste mal, dass dieser Fehler bei uns auftritt, daher ist das etwas komisch...

Um das zu vermeiden, wäre es für die Zukunft vielleicht wirklich ratsam, nur eine Animation zu erstellen und diese dann manuell zu splitten, auch wenn das etwas mehr Aufwand wäre...

Ich danke nochmals herzlich für eure Hilfe.

Wenn ihr noch weitere Ideen habt, könnt ihr die gern hinterlassen. Vielleicht findet man früher oder später doch noch raus, woran es gelegen hat.

Liebe Grüße,
Ruhn
 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006