3D Forum > Wassertropfen mit Metaballs in C4D

Wassertropfen mit Metaballs in C4D

28.05.2015 11:08
 
IrmisatoDo. 28 Mai. 2015, 11:08 Uhr
Ich habe versucht einen Wasserspritzer in C4D mit Metaballs zu erstellen. Also Metaball-Emitter-Kugel, das ganze auf 160 Frames laufen lassen. Das Gebilde in diesem Zusatand in Objekt verwandelt und per Deformer leicht gebogen.
Als Texturen verwendete ich sowohl Wasser Presets, als auch Glas, das krisslige Ergebnis war immer das Gleiche. kann das an den Metaballs liegen?

Im Schlussrendering habe ich dann im Phong-Tag von 80 auf 160 erhöht, das Ergebnis war kaum merklich besser und wurde erst durch die Kontrastierung und Schärfung im Photoshop etwas brauchbarer.


Das erste Rendering mit Alphakanal...keine Ahnung, was da passiert ist




Ein Rendering mit Standard-Einstellungen statt Physikalisch, dabei blieben die Haare auf der Strecke




Da das Rendering mit 1920er Bildschirmauflösung zu krisslig war, versuchte ich es mit doppelter Grösse, die Krissel waren nun doppelt so gross




In meiner Verzweiflung dachte ich, es liege an der Glas-Textur und versuchte einen Wasser-Shader OMG...




Falls mir jemand Tipps geben kann, wie ich glatte saubere Wasserpritzer rendern kann, oder falls jemand ein gutes Tut kennt, wäre ich dankbar.
Bitte keinen Hinweis auf Realflow/Realwave... Soviel Geld habe ich leider nicht.
Lieben Gruss, Irmi
 
KullerkeksDo. 28 Mai. 2015, 15:31 Uhr
Da die Krissel im oberen Bild auch um denHerrn rechts sind, tippe ich auf ein Problem mit dem Alpha-Kanal beim Compositing in Photoshop.
Beim Wassermaterial kannst du eigentlich nicht viel falsch machen, solange die Umgebung passt.
 
IrmisatoDi. 02 Jun. 2015, 02:12 Uhr
Danke für die Antwort, Kullerkeks.

Da Foto ganz oben ist direkt aus Cinema, da war kein PHSP dran. Mir geht's auch nicht um den Fehler, nachdem ich Alpha in den Rendereinstellungen deaktiviert hatte, war alles wieder normal bis auf die Krissen an den Rändern der Wassertropfen. wie meinst du das mit der richtigen Umgebung. Meinst du es könnte Helfen, wenn ich die Wassertropfen in einer anderen Umgebung extra rendere?
 
KullerkeksDi. 02 Jun. 2015, 19:11 Uhr
Danke für die Antwort, Kullerkeks.

Da Foto ganz oben ist direkt aus Cinema, da war kein PHSP dran. Mir geht's auch nicht um den Fehler, nachdem ich Alpha in den Rendereinstellungen deaktiviert hatte, war alles wieder normal bis auf die Krissen an den Rändern der Wassertropfen. wie meinst du das mit der richtigen Umgebung. Meinst du es könnte Helfen, wenn ich die Wassertropfen in einer anderen Umgebung extra rendere?


Ich tippe beim ersten Bild trotzdem noch immer auf einen Haken bei "Straight Alpha", ein Bild mit "Straight Alpha" ist nur für Compositing brauchbar, beim "bloßen Betrachten" sieht es seltsam aus. AFAIR gibt es dazu auch eine Erklärung in der Onlinehilfe.
Warum der Physical keine Haare gerendert hat, verstehe ich auch nicht, eventuell ist der Effekt in den Rendersettings nicht angeschaltet? Aber dazu müsste man die Szene sehen. Welche Version von C4D verwendest du (mit Nachkommastelle, bitte)?

Was die Umgebung angeht, die sollte schon mit dem Rest der Szene übereinstimmen. Woher ohne Alpha die seltsamen Kritzel kommen, kann ich allerdings ohne Szene auch nicht sagen. Kannst du da eventuell was Abgespecktes hochladen?

PS
Der Wassershader ist - entgegen des Namens - nicht für Wasser in dem Sinne geeignet (der unter "Oberflächen" im Shadermenü), er soll animierte Wellenoberflächen erzeugen. Ein Wassermaterial hat keine Farbe, einen Brechungskanal (mit IOR 1.33) und mehr oder weniger Spiegelung (bei mehr oder weniger spitzen Glanzlichtern). Deine Wasserspritzer verlangen auf jeden Fall etwas, das sich in ihnen spiegeln kann, damit das Material durch Highlights zum Leben kommt.
 
IrmisatoMi. 03 Jun. 2015, 22:54 Uhr
Das ist ein nettes Angebot, dass du dir die Szene ansehen willst. Ich muss das leider bloss bis auf Weiteres verschieben.
Bin erst mal am Umziehen. Falls ich dazu komme, die Kartons in Österreich schon auszupacken, kann ich ja mal mit dem Laptop hochladen. Ansonsten werde ich wahrscheinlich erst im September wieder mein volles Equipment fahren. Dann hoffentlich mit neuem Mobo und ordentlich RAM.
Ich melde mich wieder. Erstmal danke für die Denkanstösse.
Gruss, Irmi
 
KullerkeksDo. 04 Jun. 2015, 01:04 Uhr
Ja, zieh dich erst mal in Ruhe um
Mein Angebot bleibt bestehen, ich geh hier nicht weg.

Alles Gute und bis dann,
der kullernde Keks
 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006