3D Forum > Unity 5 - Directional Light und Culling Mask Problem

Unity 5 - Directional Light und Culling Mask Problem

02.05.2015 10:12
 
TilesSa. 02 Mai. 2015, 10:12 Uhr
Folgendes Problem. Ich habe eine Hintergrundszene. Und vorn soll das Spiel ablaufen. Die Hintergrundszene hat einen Tag Nacht Zyklus. Das eigentliche Spiel im Vordergrund soll natürlich unabhängig von der Hintergrundszene laufen. Sonst sieht man ja Nachts nichts vom Spiel. Also gibts zwei Kameras. Und zwei Beleuchtungen.

Die Objekte liegen auf entsprechenden Layern. Und die Kameras und die Lichter haben Culling Masks wo jeweils das andere Ding ausgeknipst ist.

Und Unity schert sich nen Deibel drum :/

Es bekommt sowohl das Spiel Licht vom Hintergrund ab, als auch der Hintergrund Beleuchtung vom Spiel. Im Shot habe ich dafür einmal nur das Licht für den Hintergrund an, und dann das Licht vom Spiel zugeschaltet. So wie rechts sollte es eigentlich sein.

Das Ganze ist zwar nicht ganz so dramatisch als wenn ich die Culling Layer an habe, dann ist die Beleuchtung noch mal ne Nummer krasser. Aber der Unterschied ist doch sehr sichtbar.

Die Lichtsettings sind Standard, bis auf die Layergeschichte eben.

Was mache ich denn falsch? Jemand ne Idee wie man das wirklich unabhängig beleuchten kann?
 
 
TilesSa. 02 Mai. 2015, 11:17 Uhr
Hmmm, das scheint mir mit dem GI Intensity und der Bounce Intensity zusammenzuhängen. Riecht mehr und mehr nach einem Bug ...
 
jonnydjangoMo. 04 Mai. 2015, 10:14 Uhr
Ich kann dir da nicht weiterhelfen, wollte dir nur zu der Optik gratulieren. Sieht klasse aus smile
 
TilesMo. 04 Mai. 2015, 11:09 Uhr
Danke ^^

Joa, irgendwie meldet sich zu dem Thema niemand. Selbst auf dem Mutterboard nicht. Ich denke ich werde das mal als Bug melden. Hilft ja nix.
 
SleepyMo. 04 Mai. 2015, 11:16 Uhr
Du meinst vermutlich den starken speular selbst bei Dunkelheit ?
Das liegt auf jedenfall an deiner Lichtquelle hast du mal versucht für die Nacht ein komplett anderes Licht zu verwenden ?
Bei dem anderen Licht würde ich GI dann zb komplett auslassen und alles sehr stark runterdrehen.
 
TilesMo. 04 Mai. 2015, 11:32 Uhr
Scherzkeks. Wenn ich GI runterdrehen muss bis es aus ist hab ich ja nix vom GI

Nein, ich meine nicht das Specular. Sondern das GI. Das linke Bild ist deutlich heller, weil da das GI von der falschen Lichtquelle noch mit reinspielt.

Das mit dem komplett anderen Licht geht leider nicht. Nur durch die Directionals bekomme ich die Beleuchtung die ich brauche. Das spielt ja auch noch mit dem Sky zusammen. Dass die Lichter nur bestimmte Layer beleuchten sollten ja eigentlich die Culling Masks erledigen. Das tun sie auch für das direkte Licht. Aber eben nicht für das GI.

Ich habe das aber tatsächlich grade so gelöst dass ich bei dem einen Licht für den Spielecontent die Bounce Intensity komplett auf Null gedreht habe. So leuchtet das nicht mehr in meinen Levelcontent.

Das funktioniert bei mir hier aber nur weil mein Spieleteil eigentlich kein GI benötigt. Ist also mehr ein glücklicher Zufall. Und die Levellichter funzeln nach wie vor in meinen Spielecontent rein. Ist also nicht wirklich das Gelbe vom Ei, auch wenn ich damit jetzt erst mal leben kann.

 
SleepyMo. 04 Mai. 2015, 11:55 Uhr
Ich glaub ich hab dein Problem noch nicht ganz verstanden. Ich dachte dein Problem liegt in deiner Nachtaufnahme da hier offenbar die Speukar zu stark ist.

Was ich meinte ist das du bei Dunkelheit ja kein GI brauchst.

Durch die Bounce intensity legst du ja fest wie oft dein Licht irgend wo abrallen soll also wie oft ein Lichtstrahl von einem Objekt in eine andere Richtung reflektiert werden soll.
Bei Dunkelheit gibts logischerweise wenig Licht deswegen macht es wenig Sinn das wenige Licht oft Bouncen zu lassen.
 
TilesMo. 04 Mai. 2015, 12:04 Uhr
Jo, du hast das Problem echt noch nicht verstanden. Es geht nicht um GI settings ^^

Schau dir mal das Bild oben an. Links ist es deutlich heller als rechts. Was es nicht sein sollte. Denn ich habe dem Layer das entsprechende Licht per Culling Mask komplett weggenommen. Dieses Licht das mein Level im linken Shot so hell macht sollte eigentlich mein Level gar nicht beleuchten.

Das Problem ist, das direkte Licht wird zwar gecullt. Aber das indirekte, das Bounce Licht nicht. Und das ist wohl ein Bug. Das Culling arbeitet hier fehlerhaft smile
 
defraggerMo. 04 Mai. 2015, 12:27 Uhr
du musst die Objekte auch vom default layer runter nehmen.
Also bei mir hat das bisher nie Probleme gemacht.

Edit: habs grade extra nochmal ausprobiert und du hast recht. Irrgendwie ist da der Wurm drin ...
Wenn ich ein Licht runter nehme ist alles noch super. Aber wenn ein zweites Licht dazu kommt habe ich das selbe Problem wie du.
 
TilesMo. 04 Mai. 2015, 12:29 Uhr
Juhuu, das war der entscheidende Hinweis. Wenn ich den Lichtern noch den Default Layer wegnehme ist alles gut!

Merci Vielmals smile

Kurios ist es trotzdem, denn die entsprechende Geometrie ist ja nicht auf dem Default Layer.

 
 

 


 
 
© 3D-Ring - deutsche 3D Software Community, Archiv 2001 - 2006